0

We are using SP2016 with SQL 2016 standard (13.0.5026.0 SQL Server 2016 Service Pack 2 (SP2)). SSRS feature is enabled in SQL server and service started. I am able to browse the SSRS portal with http://sqlserver/reports. Also in my SQL 2016 report builder, I can connect to report server http://sqlserver/ReportServer/

Then I setup my first datasource in a report. Connection Type is Microsoft SharePoint List. In connection string field I type in "https://sharepoint.com/sites/dev". This url can be browsed properly from my PC as well as within SQL server.

In Credentials I tried all the combination I can think of. I have tried my personal account (which is site collection admin) and sql admin and farm admin etc. All results in error message

System.Web.Services.Protocols.SoapException: An error occurred when accessing the specified SharePoint list. The connection string might not be valid. Verify that the connection string is correct. ---> Microsoft.ReportingServices.DataExtensions.SharePointList.SPDPException: An error occurred when accessing the specified SharePoint list. The connection string might not be valid. Verify that the connection string is correct. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host at Microsoft.ReportingServices.Library.ReportingService2010Impl.TestConnectForDataSourceDefinition(DataSourceDefinition DataSourceDefinition, String UserName, String Password, String& ConnectError) at Microsoft.ReportingServices.WebServer.ReportingService2010.TestConnectForDataSourceDefinition(DataSourceDefinition DataSourceDefinition, String UserName, String Password, String& ConnectError)

I have tried to upload the report to SSRS web portal (http://sqlserver/reports) and also fail in same error.

May I know what could be the problem? Is there any patch specific for this issue?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.