I took over a SharePoint site that has customized code to display a list. About two weeks ago, I changed all the groups from "Edit, Contribute, Read, and Approve" permissions to "Contribute" because I felt that it was too much permissions for a users. Well users started to get the

"You do not have the Add and Customize Page permissions, which is required to edit the contents of this web part."

error and they were not able to view the list. I put the "Edit, Contribute, Read, and Approve" back and all is well. Today, the error returned: users no longer able to view the list and they receive the "You do not have the Add and Customize Page permissions..." again.

Is this a web part issue? The web part is a content editor that is linked to a text file with JavaScript code.

  • Can you check the javascript code? In code is there anything related to permissions or group? Can you please add the javascript code to your question if possible? Commented Aug 13, 2019 at 3:05
  • @GaneshSanap, I'll have to change up the wording a bit. I'll add it to my original post.
    – adams-j
    Commented Aug 13, 2019 at 12:45

2 Answers 2


Try to copy the "Contribute" permission level and tick additional "Add and Customize Pages"enter image description here site permission, then give a new name and save. Then grant the user with this new permission level, check if the issue exists.

  • thanks, I'm sure this will work. I don't have access to create new permissions however, I did give a user Full Control to test this and it worked. The thing is, it all of a sudden did this. So there must have been some maintenance or new securities features or some other random anomaly that made this no longer working.
    – adams-j
    Commented Aug 13, 2019 at 12:54

Ok, it wasn't a permissions issue at all. It was a coding issue. Basically the code had an incorrect spelling of a field name. Again, that particular line of code was showing the access/permissions to a web part error message. Everything else was showing fine. So once that was corrected, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.