Hi All,

When I tried to installed the SPFx "npm install -g yo" getting the issues.

Tried both "npm install -g yo@latest" and "npm rm -g yo", "npm install -g yo" but it didn't help. Attached the Screenshot for regarding this issues advise me, if any wrong way i'm using. before that I have installed many times SPFx in others systems.

Response appreciated.

Thanks in Advanced.

enter image description here

  • 1
    What is the version of node and npm? Also check the issues related to ` .npmrc` file as mentioned here. Aug 6, 2019 at 6:48
  • Yesterday update the node version, Node-v updated now. Thanks Aug 6, 2019 at 7:43
  • 1
    Is it working now? Have you checked the .npmrc file? Aug 6, 2019 at 7:44
  • Not Working, same issues are getting. Aug 6, 2019 at 7:52

1 Answer 1


Have you added C:\Program Files\nodejs to your PATH environment variable ?

Follow the steps below :-

Search for the Environment Variables

Once you locate them Click on Edit Environment Variables.

Click "Environment Variables" .

In the "System Variables" option, search for "Path" and edit it by including C:\Program Files\nodejs.

Make sure it is separated from any other paths by a ;.

You may need to boot your system after this.

  • Thanks @Yash for response, I have checked it's available on the separate path. Aug 6, 2019 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.