1

I know this question has been asked a number of times in different guises.

I am after a way of either removing the animation entirely so the link tile stays static instead of animating on hover or to limit the height of the animation.

I have removed the entire hover layer but doesn't then let me add text to the tile having to resort to creating tiles with writing within the image which is not ideal.

I am using SP 2013 on prem.

Many thanks

0

This answer may not satisfy you, as it doesn't remove the hover effect but hides the rolled up element - and as it also hides the title of the Tile:

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script>
$( document ).ready(function() {
    $(".ms-tileview-tile-content a").css("visibility","hidden");
});
</script>

Embed this Code inside a Script Editor Webpart (or Content Editor Webpart) on the page.

According to another forum post also this should work (However, it didn't work for me - but I am using SharePoint Online - there might have been a change in the HTML-DOM):

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script>
_spBodyOnLoadFunctionNames.push("myCustomFunctionName");
function myCustomFunctionName() {
    $(".ms-tileview-tile-content").off('mouseenter');
}
</script>
  • Thank you, I have managed to hide the hover effect before but I then have to have the text of the tile within the tile image. Is there a way the hover effect can be disabled but the title of the tile still appear? Or whether you can suggest another tile soultion? Thanks – Dez Jul 31 at 10:18
  • I honestly couldn't find in the HTML-DOM (with Webbrowser Dev-Tools) what causes the animation. I have tried different approaches, such as unbinding all event listeners from the tiles. But SharePoint's animation always remained :( I will give you an update, when I will find out anything else about it. – SteffPoint Jul 31 at 11:38
  • I have updated my answer with an alternative I found on some other forum. It may not work, as there is a chance that the HTML-DOM of SP has changed since the answer is quite old. – SteffPoint Jul 31 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.