0

I have a missing term group in my tenant. It's not showing in the admin center where the term store is managed. So I found those very helpful PnP Cmdlets Export-PnPTermGroupToXml and Import-PnPTermGroupFromXml.

With those I was able to determine that the term group actually still exists in the back-end.

I'm able to export it and the import throws the error:

Termset ID is already present in termstore.

Is there a way of getting this term group or term set re-imported?

Thanks for your help.

  • Where did you export the termsets? from your current tenant, then re-import it again? The error shows the termset ID has existed. – Kally_MSFT Jul 25 at 7:44
  • Well, I'm doing Connect-PnPOnline https://tenant-admin.sharepoint.com/ followed by Export-PnPTermGroupToXml -Identity "termgroupID. This exports an xml to my local hard drive. Then I do Import-PnPTermGroupFromXml -Path "localpath" and I get the aforementioned error message. To me this means that the term group is still present in the term store but it can't be found though the GUI. Any idea? – colonel_claypoo Jul 25 at 10:06
  • what permission did your account have on your tenant? are you global administrator? – Kally_MSFT Jul 26 at 6:28
  • Yes, I'm the global administrator. Thus far the group 'Company Administrator' was set for the term store but I've also added my own user as well. It shouldn't make a difference as I'm automatically a member of 'Company Administrator' by way of my global administrator role. I verified and the cmdlets still throw the same error. It might try to remove the apparently existing term group but not sure if I should do that. What do you think? Thanks. – colonel_claypoo Jul 26 at 8:23
0

Please try to set your account as a Term Store Administrator like the below: enter image description here

  • I appreciate your help. Did that but unfortunately same error. It's kinda logical why the error occurs. I'm exporting a term group from the term store and importing it in the same place. Obviously it already exists. What I just don't get is why I can't see it in the GUI. Actually, executing Get-PnPTermGroup -TermStore $tenantTermStore.Id | Where-Object { $_.Name -like "*TermGroupName" } shows that there're four term groups with an identical name but different Id's- However, only one contains the term sets I wanted to restore. How can this be? – colonel_claypoo Jul 26 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.