1

We've noticed that for starting from July 19 2019, we can no longer install SPFX packages using Site Design. Here is the very minimum sample that replicates the issue:

siteDesign.json

{
    "$schema": "schema.json",
    "actions": [
        {
            "verb": "installSolution",
            "id": "{AppPackageId:ContosoCentral}"
        }        
    ],
    "version": 1
  }

Error message:

enter image description here

SPFX package is deployed to the App Catalog with no errors:

enter image description here

Installing the SPFX app without Site Designs works perfectly fine:

enter image description here

Questions

  • Does anyone have the same issue? Please, reply in comments.
  • Main question: Is there a workaround for this? Anything we can do to solve it?
  • Is there a way to get more information about the error? Install SPFX Solution: Something went wrong and we could not complete this action sounds awefully unhelpful.

Any help will be greatly appreciated!

Update

I've found related issue in GitHub: Cannot Install SPFx Solution or Activate Custom Feature using a Site Design #3543, but I don't see any resolutions.

Update 2. Quick replication steps

You can try to replicate it by using any SPFX package:

  • Install SPFx package to the App Catalog. Let's call it "ContosoApp".
  • Run the following PnP script to add a new site design
Connect-PnPOnline -Url https://contoso.sharepoint.com/sites/CommunicationSite 
Add-PnPSiteScript -Title "Sample-Site-Script" -Description "Sample Site Script that demonstrates an issue" -Content "{ `"$schema`": `"schema.json`", `"actions`": [ { `"verb`": `"installSolution`", `"id`": `"{AppPackageId:ContosoApp}`" } ], `"version`": 1 }`""
$siteScript = Get-PnPSiteScript | Where-Object {$_.Title -eq "Sample-Site-Script"}
Add-PnPSiteDesign -Title "Sample-Site-Design" -Description "Sample Site Design that demonstrates an issue" -SiteScriptIds $siteScript.Id -WebTemplate CommunicationSite
  • Apply site Design to the site via the UI: enter image description here
  • in the "id": "{AppPackageId:ContosoCentral}", i have used the product id of the SPFx package. Are you using the same ?? I got the product id by executing the Get-PnPApp command and replaced it in the site design. It works at my end :) – Gautam Sheth Aug 29 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.