1

An IT admin working for a client installed various Windows patches (along with SP patches available via Windows Update), and now two databases ("BdcServiceDatabase" and "StateDatabase") are showing the dreaded "Database is too old and upgrade is required" message. I've tried running the PSconfig command

psconfig -cmd upgrade -inplace b2b -wait -cmd applicationcontent -install -cmd installfeatures -cmd secureresources

and while this completed successfully, the databases are still "old". I've also tried running the configuration wizard; that, too, completed successfully, but the databases are still "old". Finally, I've tried running the following

(Get-SPDatabase | ?{$_.type -eq "Microsoft.SharePoint.BusinessData.SharedService.BdcServiceDatabase"}).Provision()

This command completed successfully, but the BdcServiceDatabase (at least) is still "old".

What am I missing here?

1

The following command should fix the BdcServiceDatabase:

(Get-SPDatabase | ?{$_.type -eq "Microsoft.SharePoint.BusinessData.SharedService.BdcServiceDatabase"}).Provision()

However, in my case, while actually running the command returned no errors, the command failed silently in the background. Checking the logs it turned out that for some reason the service had no SQL access to the BDC-related database. Adding owner permissions for the service user seemed to clear things up and allowed the Provision() to work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.