0

I have a custom list in my SharePoint site and there is a webpart which inserts items to that list. This implementation was working fine until recently, when we observed that there are duplicate items getting generated.

Precisely, I observed that webpart is inserting only 1 item. however, 1 more identical item getting generated after brief interval of ~5 minutes.

Following are few more details to identify the cause :

  1. item count 172000

  2. Users in site : ~2000

  3. Content DB size : 200 GB

4: Environment : SP 2013 on Prem.

Thanks

  • What type of web part is that? Is it a custom one? – Arvi Jul 23 at 0:18
  • Is there any workflow or event receiver attached on the list? – Ganesh Sanap Jul 23 at 4:33
  • @arvi - Yes it is custom visual webpart – Ashu Fouzdar Jul 23 at 14:12
  • @GaneshSanap - There are no workflows attached to it, however, there are event receivers attached and they are of following type : Microsoft.Office.RecordsManagement.PolicyFeatures.ExpirationEventReceiver – Ashu Fouzdar Jul 23 at 14:17
0

I would suggest to you check below for debugging purpose, this will give you direction

  • Check who is created by of duplicated item being created, is it same as created via webpart or a specific user for all entries.
  • Do you have any workflow being attached to that particular list? If so, what it does. is there any action creating activity.
  • Is there any event receiver attached to list?
  • Hi Siddharth, Please find my responses as follows: 1. Created by is same for duplicate item as well and both have value as 'System Account' 2. No, There are no workflows attached 3. Yes, there are event receivers attached and they are of following type : Microsoft.Office.RecordsManagement.PolicyFeatures.ExpirationEventReceiver – Ashu Fouzdar Jul 23 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.