1

I migrated SharePoint from 2013 to 2016 and then 2019. I used the database prefix SP_Intranet.

After migration to 2016, I removed SP_Intranet_Config and SP_Intranet_CentralAdmin + non-migrable databases.

This was followed by the installation of SharePoint 2019 with the latest patches. The farm consisted of four servers, the migration was successful. SharePoint server 2016 was still running but without databases. After two days in "Review problems and solutions" I got an error message: Product / patch installation or server upgrade required. .. Can you please tell me how to fix this error message?

In my opinion, since SharePoint server 2016 contained a database with the same name and continued to run, it joined the databases that were already created for SharePoint 2019.

I tried:

  1. Run the Get-SpProduct -Local after that run the Config wizard. I would use this psconfig -cmd upgrade -inplace b2b -force

  2. Clear the Config Cache on All server in Farm then run the psconfig wizard.

enter image description here

Sharepoint 2016 was installed on other servers. However, the database server is the same.

migrated from superuser.com Jul 22 at 6:29

This question came from our site for computer enthusiasts and power users.

  • Do you mean you have installed SharePoint 2019 on same server as SharePoint 2016 and run concurrently? If so I am not sure if such scenario is supported. You should have farm A your source, Farb B-2016 and Farm C-2019. Upgrade to to 2016 on farm B move the DBs to farmC and then upgrade to 2019. – Marek Sarad Jul 22 at 7:18
  • Which version of SharePoint brings you the error message? 2016 or 2019? – MHeld Jul 22 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy