1

I have installed SharePoint 2016 and SQL in the same server. While configuring Central Admin through SP Management shell i am getting error saying.. Cannot connect to the database master at SQL Server at [Sever Name]. The database might not exist, or the current user does not have permission to connect to it when creating a configuration DB. What are the steps i need to follow or what access i need to get? Any Idea?

1
  • Please provide your SP Management Shell to configure CentralAdministration. Did you already successfully create a Configuration Database?
    – MHeld
    Jul 18, 2019 at 5:26

1 Answer 1

0

Check followings:

  1. Check the permissions for the Setup account which you are using to run the wizard or PowerShell. Make sure the setup account is granted with "DB_Creator" and "Security_Admin" Server Roles.

  2. In case of Named instance, it should be "Server\InstanceName". If it is SQL Alias, make sure the alias is properly configured and should be accessible from SharePoint Server.

  3. Verify if the SQL Server Alias is created for both 32 and 64-bit! How to Create SQL Server Alias for SharePoint Check if the SQL Server Service is running on your Database Server. Verify "TCP/IP" protocol is enabled under Network Configuration section of SQL Server Configuration Manager.

  4. Test the connectivity between SharePoint and SQL Server. Try adding a HOST file entry in your SharePoint Server to point the SQL Server's IP!

  5. Check the firewall rules on SQL Server. If firewall is enabled on SQL Server, Create inbound TCP rule with ports: 1433,2383,2382 (or whatever dynamic port your SQL server is running) and inbound UPD rule with port: 1434.

  6. Double check if you have not fat-fingered User Name or Password!

2
  • In my case, enabling TCP/IP protocol made it work. Thanks!!
    – user85454
    Jul 18, 2019 at 13:09
  • @user85454 Mark as answer if it helps
    – mzonerz
    Jul 22, 2019 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.