I am configuring a SharePoint 2016 on-premise farm. I swapped the default zone url with Intranet zone url. It is because the Intranet zone url is just a server name that cannot be resolved for IP address. After swap, everything is working fine include the search results.

However the app launcher (links under left top waffle icon) and about me link (right top corner, under the user name) both still link to Internet zone.

May I know how to fix/configure the links under top bar?

1 Answer 1


Modifying the Default zone URL manually is not recommended by Microsoft as it causes such issues. It would be best to either switch it back to original URL or recreate the web application with the required URL. You can always extend the URL to different zone to host site in different URL. Manually updating any URL in Alternate access mapping is never a recommended method as its references does not get properly updated in configuration database.

  • I have to change the default zone url. It is because Search content source is suggested to use default zone url. However my default zone url is our application server name (not web front end) hence not browsable and cannot be crawled.
    – Mark L
    Jul 17, 2019 at 6:55
  • Yes, for search you need to crawl default zone url. For this option, you can delete the default the zone URL and extend it again in default zone with web front end URL. Steps: Select web application and under Delete->Remove SharePoint from IIS Website-> Select default zone site, Click on yes to delete IIS websites... Once it removes from IIS, you can extend the web application with required URL in default zone. Note: You need to be careful in performing this operation as it removes IIS sites from all servers. All make sure to take necessary backup before performing this. Jul 17, 2019 at 9:29
  • To add, if you have any customization in IIS website directly then you need to redo them as well. Jul 17, 2019 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.