0

Using SharePoint Designer 2013 I can no longer access a list data source on SharePoint Online when building a DVWP

Steps to reproduce.

  1. In SPD create a new Web Part Page.
  2. Edit the new page in Advanced Mode.
  3. Place cursor in ZoneTemplate tag.
  4. Click Insert -> Data View -> Empty data view.
  5. Place cursor in newly create DataSources tag.
  6. Click Insert -> Data Source -> and select a list.
  7. In the data source pane click refresh Data source link

error The server returned a non-specific error when trying to get data from the data source. Check the format and content of your query and try again. If the problem persists, contact the server administrator

Ran a fiddler session. get 500 response on. /_vti_bin/webpartpages.asmx.

soap:ServerException of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown.An error has occurred.

Also tried to refresh a data source on an existing DVWP with same result.

Anybody experiencing this issue?

Started within last week

I have cleared my SPD cache and tried on two different tenants.

0

I can reproduce your issue in my environment.

As a workaround, you can use Insert->Data View->select list to display list data.

  • Thanks for the reply and the confirmation of issue. I need to be able to customise the XSLT. I did as you said and selected a list to display. I then placed cursor before ending last ZoneTemplate tag. I then proceeded to insert an empty data view as originally required Click Insert -> Data View -> Empty data view. Place cursor in newly create DataSources tag. Click Insert -> Data Source -> and select a list. The data source displayed and I was able to add columns and modify the XSLT This should get me by as I can then remove unwanted markup and save the file – Billy Boola Jul 17 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.