I have a site running in SharePoint online with modern experience. And I need to make sure that the contents of the lists are searchable, when someone search in the default SharePoint search box. To do this I had already changed my Mange Result Source to "Items with same keyword as this item " as default option. I had also changed the " Allow items from this list to appear in search results? " to yes in the Advanced settings of List Search. But still, the search actions doesn't pull the data from my lists.

  1. Are there any other things to do? Do I need to create index for each columns to make it available in the search?
  2. How can I forcibly say to crawl the data after the indexing?

Note: Please be noted that, I am a newbie in SharePoint.

Thanks a lot for your help.

2 Answers 2


After spending a few hours, I was able to fix the issue I was having with my SharePoint site. Luckily I had another site where the search was working as expected, so I did a comparison with that site, and found out that, some settings are enabled in the working site.

Go to your site settings and click on Site Collection Features under Site Collection Administration.

enter image description here

And activate SharePoint Server Publishing Infrastructure option.

enter image description here

Now go back to your Site Settings and click on Manage site features under Site Actions.

enter image description here

Now activate the SharePoint Server Publishing option.

enter image description here

Please make sure that you are enabling the settings from site collection feature first as it is a dependency of the other settings.

After I did this change, the search is working fine with my list data. I am not even sure whether this is a bug in SharePoint, and what relation search has with this settings, as I am pure newbie in SharePoint.

Hope it helps.


You just need to WAIT for some HOURS or DAYS for proper re-indexing. This usually happen when you just add the user to the list or document library. I hope this helps?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.