0

Apologies for the long post: I have a SharePoint 2013 server with Reporting Services 2014 installed in SharePoint Integrated mode, plus a document library with Reporting Services content types enabled. I have a number of existing reports that have been published to a report folder in the document library which can be viewed without any issues.

The SharePoint server is in one domain (Domain A) but the developers who create the reports (including me) have development laptops that are in a different domain (Domain B).

Until now, we have been deploying reports by uploading a zip file to the SharePoint server and deploying the reports using a custom PowerShell script which also updates shared data source and shared dataset references - this method makes it easy for us to deploy the reports to different environments but is quite time-consuming to package up and run.

To speed up our workflow, we wanted to try deploying the reports to our development server direct from Visual Studio, as the deployment process is much quicker.

I have a Reporting Services project and tried deploying to the document library direct from Visual Studio 2017 using the TargetReportFolder and TargetServerURL properties.

The deployment was successful but on viewing the reports after deployment from my local machine, I got this error message: "Error - for more information about this error navigate to the report server on the local server machine, or enable remote errors".

On logging in to the server (with my credentials for Domain A) and clicking on the same reports, the reports displayed without any errors. The report folder and the individual reports have the same permissions inherited from the root site, and all developers' Domain B logins are members of the Site Owners group (which is required in order to be able to deploy from Visual Studio).

Why do I get an error when trying to view the reports from my local machine but not on the server?

  • 1
    Could you please temporary enable remote errors on the web application to see the error message? or search for it on the server logs? Maybe you can filter/search the errors regarding reporting services. – nilsandrey Jul 5 at 15:36
0

The shared data source credentials in the Visual Studio project differed from the credentials required to run the report from the server (the credentials are set in our PowerShell script).

I updated the credentials used by shared data source definition in the Visual Studio project to match those set by the PowerShell script and on re-deploying the reports, they worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.