2

Hello SharePoint Community!

So I have a Document Library with more than 5,000 documents in it. That's fine, All the documents have enough meta data that I can create good views to shorten the queried list well under the thresh-hold.

I have one such view, that is my "Quick Edit" view. It only shows documents that are missing a value from a lookup relationship from another List on the site. If this value is empty, the document shows up in this view for Quick Editing.

Now the view works fine, in the modern SharePoint Exp, BUT when you want to perform a "Quick Edit" the view understandably switches to classic for this. Issue is that once it does that I get the:

This view cannot be displayed because it exceeds the list view threshold (5000 items) enforced by the administrator.

I even get this message by switching to the classic exp, and selecting the view from the view list in classic. Very frustrating.

Is there something I am missing?

Thanks in advance!


EDIT:

After "Indexing" the Lookup Column (with no improvement), I ended up manually entering the metadata for my "Quick Edit" view... Not so quickly I might add. And even with the empty view, If I switch to classic / Click "Quick Edit" I get the thresh-hold error... So yeah, I don't get it, the view should be empty. But classic does not register that. Think there are 5000+ results.

  • Is that column (which stores the lookup relationship from another List on the site) indexed? – UBK Jul 2 at 16:37
  • No, I thought I remember reading in a rabbit hole thread that you could not index Lookups. Your question prompted me to look at the settings and am no indexing the lookup to test. Will let you know if that did the trick. Thanks! – Daniel W Jul 2 at 16:56
  • @UBK, Unfortunately that did not do the trick. View works in Modern, but not in Classic / Quick Edit. Also notice, if I put a "Sort" on the view, it breaks the Modern view as well. – Daniel W Jul 2 at 17:03
  • Hi @Daniel, Modern views are having higher threshold than classic views. I guess there are more empty items than the threshold. Is there any other column you can use to limit down the number for this column with empty items? – UBK Jul 2 at 17:29
  • @UBK, Um no not really. It is the column I am needing to fill. And at the moment there are only 147 items missing said data. I find it hard to believe the classic view cannot handle 147... I am thinking this is a SharePoint limitation. I know that in another library I have had to build a workflow to copy the String value of Lookup columns to get some views to work, but was hoping I could avoid that on such a simple filtering function, as part of it is working, in modern... – Daniel W Jul 2 at 17:35
1

For classic only:

If you filter only on indexed columns You get the threshold-warning when the result, after filtering exceeds the threshold.

If you filter on one not-indexed column You get the threshold-warning when the number of items in the list exceeds the threshold.

Also: In 2010 sorting large list was not possible. I'm not sure how that works today.

0

In sharepoint online, we cannot modify the 5000 list view threshold.

I suggest you could split the large list into some small lists.

  • This is exactly what I am trying to avoid with the views, and was the structure before. – Daniel W Jul 3 at 12:05
0

So, until I hear or find out otherwise. My issue is that Lookup columns are not stable to use when dealing with filtering or sorting as it comes to the "Quick Edit" and Classical functions.

I copied the Text values from my lookup to an Single Line Text field and filters / quick edit views worked as expected. Very frustrating.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.