I have installed SharePoint and all was working fine. Today when I go to the root website for my web application I am getting a 404. I get this on my other web application as well. Central admin is loading fine. I have checked the following:

  • SharePoint services are running
  • IIS web sites have started
  • IIS application pools have started
  • Database are up

What else could I check so I can try and work out why I am getting the 404?

Just to confirm this was all working before (This is a Windows 7 machine with SharePoint installed for development)

  • A couple of initial steps: 1) Can you successfully ping the web address of your site? 2) Are Alternate Access Mappings configured for your site in Central Admin? – Howard Jan 10 '12 at 15:12
  • 1) Ping is failing (on both locahost:80 and machine name:80) – John Jan 10 '12 at 15:16
  • 2) Alternate mapping is set up as machinename:port (this was working before) – John Jan 10 '12 at 15:17
  • Ping test don't include port numbers. What happens if just do: ping <machinename> ? – Howard Jan 10 '12 at 15:22
  • Ping works without port – John Jan 10 '12 at 15:24

I had this happen to me recently and its was because I failed to actually create the site collection. I did happen to create the webapp so all the IIS settings/db was there. In central admin verify you do have a site collection.


1) Check the databases, actually go into SQL and open the AllUserData table, make sure you can open it (using the same identity as SP)

2) Check ULS logs?

3) Check event viewer?

4) Check hard drive space on all servers in farm, make sure you have at least a few gigs free.

  • 1) All working fine – John Jan 10 '12 at 15:28
  • 4) 400GB+ Free space – John Jan 10 '12 at 15:28
  • 3) All looks good, get a complaint when i try to access via localhost about not setting up alternate mapping. When I put the machine name in no error – John Jan 10 '12 at 15:37
  • 2) Again no errors that I can see... – John Jan 10 '12 at 15:40
  • machinename works but localhost doesnt? – David Lozzi Jan 10 '12 at 15:48

Related: SharePoint 2010 New Installation - Site Collection

Answer by Greg Hurlman:

Double-check the Site Collection List in Central Admin, make sure your site is listed there. If it is, if you haven't been able to make use of the site yet, delete & recreate the site collection. If the same result, and this is the only site collection on the web app, delete & recreate the web app as well.

Were there any errors on install? What install method did you use (Setup Wizard, Config Wizard, and Farm Configuration Wizard, Powershell scripted install)?


Resolution Steps (Worked for me):

Go to application pool of Central Administration.

Right click on it and go to Advanced Settings

In the Process Model section, increase the shutdown time limit to 200 for example.

It is a good idea to restart IIS now.

  • This worked for me. Insane, nothing hinted in this direction. No ULS Logs, no Event logs. – Jeroen Ritmeijer - Muhimbi Jul 25 '18 at 13:26

Please check if the 'Alternate Access Configuration' is correctly set. Sometimes, when the IP is listed as 'Default', this issue can occur. Change it to 'Extranet' and provide the IP instead of the URL if required.


In my case an db detach attach for the specific sitecollection helped me out of the cave :) But it was an sharepoint 2013 environment!


I had the same issue and tried everything above commented, my solution was START the "Security Token Service Application Pool" (IIS Manager -> Application Pools), for some reason was stoped

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.