0

I configured SharePoint 2016 Enterprise Search and everything work good my crawling has not any error and crawl all files my main issue is in the search result some files if I do not write it in full name I can not get result ex: I have EXCEL file named as 001610458996 I want that if I wrote middle numbers get me the result or just first 5 numbers I put star also but still not getting any result but if I write it in full number like 001610458996 then I can see that file its same for all other files also if a file name include any symbol I have to write \ before that symbol then I can get the result how to fix that to give my any result I type Regards,

1

What you describe is the normal behaviour of SharePoint. If you look at the Documentation you'll notice that only prefix-matching is supported, suffix-matching is not.

In your case: searching for 001* should work (if the name is part of the fulltext-index) whereas *996 will never work.

  • thanks so much for your answer so there is no way to make my search find files even it was written half of it and it never return back files name which is include symbols – baban jamal Jun 27 at 9:57
  • Actually the issue is that even in advance search I can not search as I want I wrote just 4 middle number in advance search and still have same issue – baban jamal Jun 29 at 11:51
  • There is no difference in search, when in advance mode. Only the UI is different. The same restrictions still apply: Suffix-matching is still not supported. – Nils Jun 29 at 15:08
  • Thanks Nils for your reply so there is no any way to get in result what I want brings what you time even half name of file – baban jamal Jun 29 at 22:38
  • No. Only if you search from the beginning (i.e. "001*") – Nils Jun 29 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.