I have set up a workflow that will email a person or persons in a People Picker field that allows multiple values. However, the Workflow doesn't work and shows this error:

RequestorId: 64fb8be0-4f83-3135-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.InvalidCastException: The value 'd/results(0)/residentsId' cannot be read as type 'String'. at Microsoft.Activities.GetDynamicValueProperty`1.CheckedRead(String propertyName, DynamicItem value) at Microsoft.Activities.GetDynamicValueProperty`1.Execute(CodeActivityContext context) at System.Activities.CodeActivity`1.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

With some research, I saw that it was related to how the email addresses get formatted for People Picker fields that allow multiple users. I implemented the fix of changing the Return field as to Display Names, semicolon delimited and Login Names, semicolon delimited, but neither of them work still. Images below are of my workflow and list settings.


email setup


People picker settings

1 Answer 1


Is there as a 'Return field as' email addresses, semicolon delimited? In my non-infopath form there is, I have several emails sent from the workflow this way. I was always able to select email addresses.

I will add an advice. If this field in your form is empty (if it is not mandatory) it will fail the workflow.

When the result from people picker is null (no person is selected) the workflow will not handle the issue and simply fail.

  • Yes, that is an option but it does not work either. I have also changed the People Picker to not allow blank values, but that didn't make a difference as I have been testing by always filling out that field, never leaving it blank.
    – Nicole
    Jun 20, 2019 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.