0

I got an error while try to run PSConfig."Feature 'f10fa067-3342-4d85-b5ac-92525d3491a7' for list template '10002' is not installed in this farm"

I did not find this feature neither in FeatureAdminTool nor with PowerShell. Only I find this in AllList table in Content database.Even I did not find in Features Table in Content Database

How to remove SharePoint Feature from Database

Anyone had faced this issue? Please help me to find solution for this.

1

Issue :-

This error happens because a list or library was created in your SharePoint site based on a given list template that is no longer available.

A common scenario for this type of error is a list that was created with a template defined by a feature that has since been uninstalled. This makes the list invalid because the template no longer exists.

Solution :-

Re-install the feature in your SharePoint farm to make the list template available again .

created on a custom template.

I suggest you get list template feature ID via following PowerShell code:

$SPWeb = Get-SPWeb "http://SiteURL"

$SPList = $SPWeb.Lists['ListName']

write-host $SPList.TemplateFeatureId

Then access List Template Gallery (_catalogs/lt/Forms/AllItems.aspx) to check if this template exists or has been checked in.

  • Thanks @yash.kamdar, Here the problem is, we did not find this feature solution code in our local repository. Please suggest me how to create a feature with the same feature GUID. – Srinu Dasari Jun 22 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.