3

I have created a site in SharePoint 365. I am the owner. I have full control. Yet when I do specific actions (e.g., change the navigation settings) I am told that I must request access. I do this and the request comes to me. I approve myself to have access but nothing changes. I am still unable to complete the action. SharePoint still prompts me to request access.

Here are my permissions as originally set up by default with the site.

Here are my permissions as originally set up by default with the site.

enter image description here

  • Is this a Modern Team site? – Trevor Seward Jun 18 '19 at 20:21
  • Is this inside a corporate tenant of some sort? I work for a large organization and within our tenant certain features aren't enabled. I experienced something very similar to what you are describing if I tried to enable those features. – Rothrock Jun 18 '19 at 22:49
  • I am testing Modern and Classic. This one happens to be my Classic site, but I see the same behavior in both. Yes, this is a large corporate site. This particular error instance is when I try to show subsite navigation in the site or site navigation in the subsites. – Richard Jun 18 '19 at 22:52
1

When you approve access via email it adds you to an existing group in that site(if the settings for that group is wrong Nothing will change

There are several ways to test this. I would take the following action to see what is the issue. From what I see you have put some exception on the group permission First Try to add yourself Directly to that Site on your site Click Share>Share With>Advance This will open the Permission setting for this site now add yourself to directly to the site(from grant access) Your Permission window should look like this enter image description here

If this works It means The settings for the existing groups is wrong.

There is another possibility. There setting for Permission level might be wrong. for this purpose Click Permission levels, then in the new page click on Full Control and edit the permission. this will solve the issue!

| improve this answer | |
  • Thank you all. I think this is a setting from the tenant admins. Nothing I do seems to fix the problem. I specifically assigned Full Control and I see that Limited Access is assigned by default and I can't change it. See the screen clip I added to the question section above. – Richard Jun 19 '19 at 1:18
  • 1
    What you are seeing is the default behavior of the permissions structure. I would advise you not to edit group permissions. As with On Prem SharePoint, the best way to grant Permissions is through the Site Settings>Permissions setting rather than Sharing through Email. – John Wills Jun 19 '19 at 12:36
  • @Richard did you try to give direct permission to yourself. through site permission? It should do the job. the solution should work. I normally spend days defining permission levels and permission groups in O365 based on the customer need. in that case you will have correct categories in email. – Ehsan Aliverdi Jun 19 '19 at 22:51
  • 1
    Another suggestion is , as your question is about office 365, Sharepoint I strongly recommend you contact Microsoft and submit a ticket via the admin Portal. As we can not check your tenant but they can. they are so helpful and fast. – Ehsan Aliverdi Jun 19 '19 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.