1

I am Unable to provision Secure Store Service Application for SharePoint 2013. I get TLS related error. Below is the error:

Logging unknown/unexpected client side exception: SecurityNegotiationException. This will cause this application server to be removed from the load balancer queue. Exception: System.ServiceModel.Security.SecurityNegotiationException: Could not establish secure channel for SSL/TLS with authority 'sm000000:32844'. ---> System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel. at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context) at System.Net.HttpWebRequest.GetRequestStream() at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStream() --- End of inner exception stack trace --- Server stack trace: at System.ServiceModel.Channels.HttpOutput.WebRequestHttpOutput.GetOutputStream() at System.Serv... f968df9e-3ece-009d-d25e-28f479736e4a

7
  • Have you validated your TLS config? Turn on CAPI2 logs in Windows Event Viewer and try to recreate the error you should get more information about the nature of the issue. But it looks like one of the components is not configured for TLS (or miscofigured) Commented Jun 18, 2019 at 11:38
  • I have enabled CAPI2 logs. Below is the log I am getting: Commented Jun 24, 2019 at 11:16
  • A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. Commented Jun 24, 2019 at 11:16
  • Try exporting root and adding it to trusted root on the servers. Commented Jun 27, 2019 at 7:50
  • It is already there. Commented Jul 22, 2019 at 10:59

2 Answers 2

0

There a blog about configuring Secure Store Service Application, you can check it with your steps.
How To Configure Secure Store Service Application In SharePoint

If this issue still exists, you could provide your steps to analysis this issue further.

1
  • I have followed steps in the article mentioned by you but still I am facing the same issue. Commented Jun 24, 2019 at 11:17
0

I was able to resolve this issue by enableing SharePoint support for TLS 1.1 and 1.2 by following Enable TLS and SSL support in SharePoint 2013 article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.