0

Recently manager of few users in AD have been changed as old manager has left the organization. But this change is not reflecting in user profile. I have done full sync as well but no luck.

Please help me with this.

Thanks in advance!

  • Try to update other fields as well in AD and you will encounter same problem. Can you please the screen shot of error as suggested by yash.kamdar? – Sohail Shaikh Jun 17 at 11:26
  • In this case, try deleting the manager name > Save > Enter manager name again > Save and run the sync again. I hope this will solve the issue. – Anand Sep 5 at 9:56
0

Make sure the User Profile Service and User Profile Synchronization Service are started.

Make sure you have configured synchronization connection, and you selected the right OU, the user is contained in the OU.

Navigate to CA->application management->Manage service applications->user profile service application->configure synchronization->recreate the synchronization connection or repopulate containers:

Then start a full sync.

If the issue still exists, check the ULS log to determine the exact cause of the error at below location in directory :-

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS

  • There is no issue with connection. Also syncing is also working. The only problem is that its not updating manager field. Also i check logs but did not find any error. – ARD Jun 17 at 11:55
  • Are you using out of the box profile synchronization ? – yash.kamdar Jun 17 at 12:15
  • Yes, I am using out of box profile synchronization. "SharePoint Profile Synchronization" – ARD Jun 17 at 12:39
  • One thing you can try is delete the Manager property and recreate it . Try full synchronization after this .Suggesting this approach since you are not encountering any errors in the Logs – yash.kamdar Jun 17 at 13:04
0

The best work-around for the following issue is:

  • Open each user's profile
  • Go to Manager's text box
  • Delete the following Manager
  • Save
  • the profile again
  • update the manager
  • save.

The following will surely update the manager field.

This can also be achieved with the help of powershell script to automate the process for all the users.

Hope this helps.

0

During troubleshooting, i found that the account being used for syncing the users were got disabled. Enabled the account and this resolved the issue.

Thank you All.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.