0

I'm trying to get a Workflow to run, triggered by an information policy and its simply not working. I've set up minimal test cases and they aren't working either. Here's what I've tried/tested so far.

  1. Information management policy is set to run daily - and is completing with status 'successful'
  2. Expiration policy is similar set to run daily, about an hour after the IMP is also successful.

I've also been testing with Run Now.

I've set up two lists for testing.

IMP test 1 has an information management policy associated with items.

Snapshot of the policy

Its set to trigger on creation + 1 day and send me an e-mail and then keep repeating every other day.

Imp test 2 is the same except the policy is associated with a test content type (IMP test) rather than a list item.

Result

  • The List based on items doesn't do anything - Expiration date never seems to be populated with a date and the workflow isn't triggered

  • The list based on content types gets an Expiration date set, but again, the workflow doesn't run.

Been banging my head against the floor for this one for a couple of weeks. Any ideas?

0

Did you check the "Source of Retention"? There are two options under this setting.

  1. Content Types

  2. Library and Folders

    • It should be set as "Content Types", to proceed content type based retentions.
    • Else the retentions of the "Content Types" will be overridden by the "Library and Folders" retentions.

Find this option in this path: Go to "List Settings"-> "Information management and policy settings" -> Find the "Change Source" link.

If you are okay with the above and still WF not getting triggered, then please try below and let me know the result.

Set the condition as "Created Date + 0 (days)"? And run the "Information management policy" and "Expiration Policy" timer jobs manually.

  • Thank you for your help @xavi. I've done as you've suggested with the content type-based list. Source of Retention is the Content Type, condition is 'Created+0 days'. Run the jobs manually in that order, with a 5 minute wait between IMP and Exp. 'Expiration Date' is populated on item creation with today's date. However the workflow (which simply sends me an e-mail) is still not triggered. – Chris N Jun 11 at 12:16
  • are you sure that the "Information Management" policies are working? Please change the "Start Workflow" action to "Move Recycle bin" to confirm this. Let me know the status. – Xavi Jun 11 at 16:10
  • Interesting. Thank you for this suggestion. On running the IMP and Exp jobs, the items are immediately transferred to the recycle bin. Switched it back to running the workflow? - not a sausage. If I manually run the workflow from an item, the e-mail goes out. Its a Sharepoint 2010 workflow with a single email statement. I'm still baffled. Any thoughts on where to go now @Xavi ? – Chris N Jun 12 at 8:50
  • Please let me know, where the related list is present? whether in the "Root Site" or in the "Sub Site". – Xavi Jun 12 at 18:07
  • The list is in the root of the site collection @xavi – Chris N Jun 12 at 23:18
0

All the bizarre IMP behaviours turned out to be due to the databases not being updated following a software patch. There's a life lesson there, somewhere.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.