0

I've added content types to a list, and I want only 1 to appear on the "new" menu button. To do this, I've set only the single type to be visible on the "new" menu, and thus it is the default type. Well by hiding the others, they no longer even show up in the "Content Type" selection drop down in the item form.

This is not how I remember things working in recent memory. I'd expect all content types to be selectable in the item form. This is all in "Modern" SharePoint Online. Am I forgetting something or has this behavior changed?

  • How do you set only the single type to be visible on the "new" menu? – Lisa Chen MSFT Jun 12 at 10:08
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – MHeld Jun 12 at 10:50
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review – Ganesh Sanap Jun 12 at 10:55
  • How do you set only the single type to be visible on the "new" menu? – Lisa Chen MSFT Jun 14 at 8:29
  • @LisaChenMSFT I did so by deselecting all other content types from the "appears on the new menu" check boxes in the list settings. – mgallagher Jun 15 at 21:19
1

If you deselecting all other content types from the "appears on the new menu" check boxes in the list settings, it is by designer that they no longer show up in the "Content Type" selection drop down in the item form.

  • A bit counter intuitive, but it is what it is. I figured the "new" menu setting to be controlling what can be selected on initial creation, but after that all other content types are fair game. – mgallagher Jul 3 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.