1

I am working on an enterprise wiki site collection inside sharepoint server 2013 professional farm. now i want to write a power-shell command to update some custom fields values for the wiki pages, including a drop-down field named "Catefory" and a metadata field named "Wiki Type". but i do not want this to update the wiki pages' Modified Date & modified By + i do not want any remote event receiver to get fired or any list workflow.. so are there any available power-shell commands for achieving this?

1

From the question, it is unclear that you want to alter the schema of wiki page library or want to update the item metadata columns. Since you mention Modified By or Modified Date should not update, I guess here you are working on item metadata update.

In PowerShell you can SharePoint CSOM. They key point here is to use SystemUpdate() method rather than Update() method. Read more on this at https://docs.microsoft.com/en-us/previous-versions/office/sharepoint-server/ms461526(v%3Doffice.15)

But the downside of above workaround is it still triggers the Event Receivers and WF. Stop Workflow Triggering When SystemUpdate is called

  • thanks for the reply..i updated my question to make it clearer, and yes i want to update the wiki pages' custom fields,including a drop-down field and a metadata field .. so there is not anyway to update those values without triggering event receivers and list workflows? now in my case i will schedule to run the powershell each hour so i can not stop the workflow or the event receiver during the execution of the powershell. any advice? – SharePoint TestDev Jun 6 at 22:53
  • I believe there is no other way to stop event from firing. You need to disable them before updating the content. Once the content is updated via SystemUpdate method, you need to enable them. Otherwise it will keep triggering. You can do it for each line item. Use the link given below to read more on how to achieve it. The code is for SSOM but you can easily convert it to CSOM for powershell. – ThinkB4Code Jun 7 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.