0

I am working on a sharepoint famr 2013 professional, and inside an enterprise wiki site collection, when i tried to access the "Site columns" to create a new site column i got this error:-

enter image description here

now i checked the site features and seems there are many site features for bamboo, but when i tried to disable the 2 active ones, i got unexpected error, here are the site features:- enter image description here

also inside the central admin >> farm features, i got 2 features as follow:- enter image description here

so can anyone help me , in removing this feature and the corrupted field type? as i am unable to create site columns... Thanks

One extra note. Now i access c:\windows\assembly\ and i got some assemblies for bamboo:- enter image description here

so can i try to uninstall them?

0

The error message means that you have a column whose type is BambooKBRichText is used in lists, but that type does not exist in your new environment.

One suggestion is you can write code to check where this site column has been used in lists or library. If used please delete the list.

$web = Get-SPWeb -identity http://tvstg01/
$list = $web.Lists["Risk & Issue Management"]
$column = $list.Fields["BambooKBRichText"]
if ($column)
{
  Write-Host "Column BambooKBRichText exists"
}
else
{
  Write-Host "Column not found on this list"
}

If the column doesn't exist then the $column object will be null, which evaluates as $false in an if statement. If the column does exist then it'll be evaluated as a $true

Similar issue post for your reference:

https://social.technet.microsoft.com/Forums/office/en-US/20a7217c-af8b-477b-a6ff-2ff057370b5e/unable-to-access-my-site-column-and-unable-to-delete-the-a-custom-field-type-using-power-shell?forum=sharepointgeneral

  • i run the script on all the lists but i always get "Column not found on this list" .. i also modified the script to search the web instead of the lists as follow $column = $web.Fields["BambooKBRichText"] if ($column) for the field but i get the same result .. so not sure if ur script is suppose to fix the issue... also in the error shown inside my original question, it says that Field Type named BambooKBRichText.. so it did not say a field, it says a field type, while the script you provide will search for the fields and not fieldtypes... – SharePoint TestDev Jun 8 at 1:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.