0

I've a problem with our SharePoint online (hosted by MS), we had a list with a bunch of calculated columns and lookup columns on top of normal columns. I had created some customized forms via Sharepoint Designer 2013 for adding new items, editing and displaying, all worked fine.

At some point I guess there has been an update on the platform that have messed up my list. Now I'm unable to create new forms, when trying to do that I get the error message: Could not save the list changes to the server.

I've checked MS Roadmap for Office 365 and I can't find anything that could explain what's happening.

I've searched the interweb and found that this error could be because of errors in calc columns or lookup columns trying to look for data in non existing lists.

I've checked all my lookup columns and all my calc columns but they are all correct, the formulae are correct and not generating any errors, the column names are also just plain text and don't contain any symbol.

Given my permissions on the site have not been changed, I've did few tests and I've found out that if I delete all calculate columns from this list then I'm able to create forms, the moment I add any calculated column I get that error again when trying to create forms.

The last test I did is to create a brand new list, add a bunch of columns normal and calculated. When trying to create a form, I have no problem and the form get created.

My conclusion is that my old list somehow got messed up during the update, but I can't tell what it is. I've contacted our internal support team but they are useless, so no hope in finding help there.

Now before I embark in the tedious task of manually moving the data across from this list into a new list (have only few hundreds of records in) I was wondering if somebody came across this problem and solved it, it would be greatly helpful.

P.s. I've also saved the list as a template and created a new one based on the template, so to carry over the data.. but that carries over also the corruption or whatever is wrong with the list as I can't create forms on the list copied either. Only works on new lists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.