I am working on custom item template. However, when I made changes in template, this didn’t seem to reflect my changes…

Using the debugger of chrome, I saw the old version of the js files were still used for the item templates. Somehow these where cached…

If I clear my browser cache, then it's working fine. But I don't want to clear my cache or do a hard refresh after every changes done in item template…

Need suggestion to fix this…

2 Answers 2


If you do not want to clear browser cache, you could change the name of the js file such as filename_v1 which you use for the item template.

  • for the item template or display template, js file is automatically created with the name of item template or display template. Jun 3, 2019 at 15:48

Disable the cache while developing.

In IE it's called "always refresh from server" and can be found using developer tools (F12).

enter image description here

For Chrome it's simply called "disable cache":enter image description here (also in developer tools)

  • this is happening on Production, I can't tell my users to disable cache. Jun 3, 2019 at 15:49
  • Interesting. Never had that "in production". Are you using BLOB cache or page output cache in the farm?
    – Nils
    Jun 4, 2019 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.