0

I'm having a heck of time trying to figure out why a particular site collection won't allow an Infopath 2013 form publish to a Sharepoint list.

I'm working in Sharepoint Online 365.

I've tried a Powershell command to deactivate and reactivate as recommended by numerous folks but to no avail. I mean the commands worked but it had no effect on the form successfully publishing.

Another thing recommended involved deactivating and reactivating Enterprise Site Collection. No effect either.

Anyway, list forms will publish from Infopath in the rest of the site collections under the main domain. Now I'm just trying to understand what happened so if it happens again I'm not copying everything to a new site collection again.

Another thing to note is we're using classic pages with a lot of CSS and HTML.

Any thoughts?

enter image description here


Edit

Hellofiona. Thanks. I can access the _vti_bin link ok, but the Customize in Infopath button indeed does not work. I had been editing the form through "Form Settings" and "Customize with Infopath."

I also ran Fiddler via Marek's suggestion and it came up with one line of error under "services_forms":

HTTP/1.1 500 Internal Server Error (and this subsequent code:)

<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><soap:Fault><faultcode>soap:Server</faultcode><faultstring>Server was unable to process request. ---&gt; Activation could not be completed because the InfoPath Forms Services support feature is not present.</faultstring><detail /></soap:Fault></soap:Body></soap:Envelope>

A site collection where the form works properly produced this in Fiddler:

   <?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Body><GetListFormLocationResponse xmlns="http://schemas.microsoft.com/office/infopath/2007/formsServices"><GetListFormLocationResult>https://company.sharepoint.com/sites/name/Item/template.xsn</GetListFormLocationResult></GetListFormLocationResponse></soap:Body></soap:Envelope>

It looks like there's a faulty "GetListFormLocationResponse" in the dysfunctional site collection. Does this make any sense?

  • You could try debug with fiddler. Compare the web response from working and non-working site. – Marek Sarad Jun 3 at 8:01
0

Try to troubleshoot your issue as following:

  1. Switch to another user account and publish to the list, check if the issue exists.

  2. If you can customize the form via LIST ribbon->Customize in InfoPath button?

enter image description here

  1. Check if you can access https://tenant.sharepoint.com/sites/sitename/_vti_bin/FormsServices.asmx url in the browser.
  • Sorry. But this did not solve my problem. – ironsledge Jun 6 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.