I'm trying to restore a SPSite using Restore-SPSite command.

The command returns :

Restore-SPSite : Your backup is from a different version of Microsoft SharePoint Foundation and cannot be restored to a server running the current version. The backup file should be restored to a server with version '' or later.

However, when I take a look at http://<centraladmin>/_admin/PatchStatus.aspx, everything has a greater version number than

Why does it occurs and how can I work around that ?

PS: Both source server and target server are running the June CU.

2 Answers 2


Do both machines have the same license, ie: standard vs. enterprise?

I have run into this before and didn't have the time to troubleshoot why it didn't see the versions were the same; my fix was to do a SQL backup of the applicable content database, restore that to my target environment, and attach the content database to the target farm. If SharePoint believes the DB version is older than that of the farm, it will upgrade the DB when it attaches it.

That route may or may not be an option for you, but something that might be worth trying if you're in a bind.

  • 1
    This worked. Both farms were running Enterprise licence. I found however, that my source farm has not the SP1 properly applied. I backup the SQL DB, restored it on the target farm sql server, attached it and called Upgrade-SPContentDataBase. This solved the issue. Thanks
    – Steve B
    Commented Jan 9, 2012 at 10:07

The version number '' suggests that your farm is running with Enterprise license, but without SP1. Once your farm is upgraded to SP1, the version number should change to something like- '14.0.6029.100'.

I strongly recommend you to run the SharePoint configuration wizard, so that the changes get affected after the SP1 installation. Then you will be able to do a restore properly.

  • same error... I reinstall the June CTP to be sure, reapply PSCOnfig... with no sucess
    – Steve B
    Commented Jan 9, 2012 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.