0

Env: sharepoint 2013

I have a document library where we have custom infopath forms. There are many completed forms files stored in doc library which we can open and view after clicking on the name of the xml files.

However there are 3 files which do not open and give the below error:

All other files opens up fine. I am scratching my head over this to no avail !

Error There has been an error while loading the form. Click Try again to attempt to load the form again. If this error persists, contact the support team for the Web site.

Click Close to exit this message.The following document is not a valid InfoPath form:

When I download the xml file and open it up, it comes up as blank.

Please suggest.

1

I think you are using Forms library not Document library (as you have the xml files in the library). If xml file in library is blank there is something wrong with the item (and InfoPath services will not be able to do with it anything). Issues may differ from problems during saving to data corruption on the DB side. If the latter you can try restore item from backup and see does it work and then restore it to your production environment.

  • Thank you. You were right. We had migrated in the last year sept and these items were having issues since then. We had to delete the item and recreate them again. – Deepika Jun 14 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.