0

I have a SPD 2013 Workflow on our PWA site that has been working fine for 6 months. My colleague has left the business and Admin have disabled his 365 account.

Suddenly, the Workflow is failing and not pulling the correct info through.

I added email commands to the workflow to send me the contents of the dictionary variable straight after the API call for assignments and get the following:

{"error":{"code":"-2147024891, Microsoft.Office.Project.Server.Exceptions.ProjectServerUnauthorizedAccessException","message":{"lang":"en-US","value":"Access denied. You do not have permission to perform this action or access this resource."}}}

The Workflow/Email is shown below:

enter image description here

Email command

I have made sure I am a site owner, I have re-enabled my colleagues account as it was before he left, but it still fails.

The list workflow is triggering as me as the initiator now, where before it was my colleague.

I am not an expert on API/Workflows and cant figure out what im missing, currently this is affecting us being able to import project tasks to our SharePoint lists to schedule engineers.

Any Ideas what I need to do to get this working again would be extremely appreciated.

Many Thanks Dean

  • From Error message it is clear that its related to Permission. Check and compare your colleagues permissions on the PWA site with your permission. Add yourself in missing PWA/SharePoint groups if any and try again. – Swapnil Lad May 29 at 6:46
0

Thankyou Swapnil Lad.

I resolved this in the end with your advice.

I had tried giving full control to workflow App and using the App-Step method and it made no difference.

It was indeed a permissioning issue.

I, and my Leaver Colleague were both in the relevant Groups as Administrators and no one else has these permissions so had nothing to reference.

So I just deleted us both out, and added new instances of us back in again as Administrators.

For some reason that did the trick.

If anyone knows why that would be, based on my colleagues O365 account being temporarily disabled and then re-enabled again, then feel free to add comment.

Many Thanks Dean

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.