0

I'm using a video hosting service that provides me with embed codes for the videos: something like this:

<iframe title="Part 1" width="640" height="360" allowTransparency="true" mozallowfullscreen webkitallowfullscreen allowfullscreen style="background-color:transparent;" frameBorder="0" src="https://app.vidgrid.com/embed/--video-id--"></iframe>

This works totally fine if embedded by a contributor on a SharePoint page (clicking "Add A Page > insert > Embed Code") because I have added the video's domain (app.vidgrid.com) to the HTML Field Security allowed list. But. We have a Video Library ("Libraries > Training Video Library > Add > Video") which also allows video iframes, but the contributor sees this error (works for me, as an admin):

Create new video from vidgrid gives error "the embed code is invalid because the source of the embed content is not allowed"

My guess is, SharePoint isn't using the HTML Field Security allowed domain list for this video embed piece. Is there any hope? :D Or does everyone just need to add a full page for each video, or download the video as an MP4 and re-upload it to sharepoint (works but clunky).

  • I'm facing the same problem. Only Site Collection Administrators can add Videos to a Video Library using iframe embed code. Is there a resolution for this problem? – cjmorelock Feb 7 at 16:43
  • Unfortunately none that I ever found :( sorry! – Ryan S Feb 13 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.