1

We are using cross-site publishing with a library in Site A and surfacing the content in Site B. Here is documentation about cross-site-publishing. About 2/3 down the page is a section about Content metadata in the search index.

...To include crawled properties in the search index, crawled properties are mapped to managed properties. This is because only managed properties are included in search results. ...

I took that to mean that only managed properties are included in the cross-site published catalog search.

We have a list field called Catalog notes which the admins use to keep some notes about the entries they are working on. Words that appear only in the notes are providing hits on Site B -- they appear as results and hit highlighting.

We don't want this "admin only" column from Site A to be included in Search results in Site B.

Since it is list field it has a crawled property and no managed property, so it shouldn't be included in the search results according to the above quote. I checked in the Site Collection > Search Schema to make sure that a managed property wasn't generated and there isn't.

I found this tutorial which shows how to exclude a column from SharePoint Search Crawl. Site Settings > Searchable columns. I tried that but the Catalog notes column doesn't show up there because it is not a site column -- meaning it shouldn't be indexed to begin with!

There is a crawled property ows_CatalogNotes. When I edit the crawled property I see it isn't mapped to anything. But I think the issue might be that the "Include in full-text index" is checked. It is also not available for me to change.

Any ideas how to prevent this library list column in Site A from being indexed and included in search results in Site B? (Or from search results anywhere if that is easier!)

Edit

I found What makes a SharePoint column searchable? which shows that if there is a crawled property with full text index, but a mangaged property that is not searchable, that the column will not be searchable. I've tried mapping Catalog Notes to a managed property called NoSearch and we'll see if that works. Fingers crossed!

0

There is an option in site settings. In your case it would be Site A.

http(s)://<Site A URL>/_layouts/15/NoCrawlSettings.aspx

And then select "Exclude" for the column that you want to not be indexed.

  • Thanks BigRaj that is the page that the tutorial showed me. Because my column is not a Site Column it doesn't appear on that page. – Rothrock May 15 at 20:27
  • Is recreating the column as a site column and attaching it to the list content type a viable option? Data can be copied into the new column via code or workflow. – BigRaj May 16 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.