0

I have a SharePoint Online list library which allows users to create a list item by using a simple form.

In the backend of this site I've configured some hidden columns which are needed for some workflows to operate. Within the content type's settings I have set these fields as "hidden" like below.

enter image description here

However, when I click + New to create a new list item, these hidden columns (or fields) are still showing in the form. Is there any way I can hide them? They weren't previously visible and for some reason are showing now, but the hidden feature appears broken?

enter image description here

0

If you set the fields as "hidden" in the content type settings, it only works for classic experience in the list.

If you want to hide the columns in the forms in modern experience, then you could customize the forms in PowerApps.

In the PowerApps, select the fields which you want to hide and set “Visible” as off like the picture below.

After all, you should save the changes and publish to SharePoint. Click File in the ribbon->save->Publish to SharePoint.

enter image description here

  • A few days ago the hidden columns were being hidden absolutely fine in the modern experience, they've seemingly just stopped working out of nowhere. I'm also unable to use PowerApps since the form includes some append-only comments, something which PowerApps does not yet display correctly or support. – Toby May 15 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.