0

I have Yeoman generator (@microsoft/generator-sharepoint) version 1.8.2, I can verify this by running: npm list --depth=0 -g .. When I try to run yo @microsoft/sharepoint , I noticed 2 things:

The wizard doesn't show support for SharePoint 2019, so it only gives me the choice of SharePoint online only, or SharePoint 2016 onwards. The second thing is that the project scaffolded shows this:

    "@microsoft/sp-core-library": "1.5.1",
    "@microsoft/sp-webpart-base": "1.5.1",
    "@microsoft/sp-lodash-subset": "1.5.1",
    "@microsoft/sp-office-ui-fabric-core": "1.5.1"

What do I need to do to get the latest version of SPFx? (1.8).

3
  • 1
    If you're developing for SharePoint Server 2019, the highest SPFx version it supports is 1.4.1.
    – user6024
    May 11, 2019 at 22:29
  • Thanks @TrevorSeward. But I am not even getting the chance to choose sp 2019 in the first place. The yeoman wizard gives me the option to either choose SP online or sp 2016, if I go with SP online, I'd get SPFx v 1.5 only. May 12, 2019 at 23:32
  • I'm getting the exact same issue now. Any other ideas on how to fix. I've uninstalled/reinstalled node and updated to SPFX v1.10 but still getting 1.5.1 only. Jul 6, 2020 at 13:06

1 Answer 1

0

I have had this issue before and it was because one of the following:

  • there was a .yo-repository in a higher directory
  • need to run npm install -g yo@latest @microsoft/generator-sharepoint@latest
  • node_modules folder in a higher directory

Comment if any work for you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.