Using SharePoint Designer, I am trying to create some dummy listforms (newform1,editform1 or displayform1) but when I create one it pops up the following error.

"could not save the list changes to the server"

and even when I try to edit the existing list form lets say the newform.aspx and try to insert the SharePoint control "custom list form" it does not get drop in the form.

  • Hi! How about logs? Where are may be some meaningful rows. In additional, it may be permissions problem.
    – IAfanasov
    Commented Jan 5, 2012 at 7:44
  • Have you considered customizing with InfoPath?
    – Lori
    Commented Jan 6, 2012 at 14:38
  • I have to say I had this problem and confirm that PirateErics Solution solved my problem. Great Job. Thanks. Was initially very worried I have to say as list was huge.
    – user11470
    Commented Oct 19, 2012 at 9:38

5 Answers 5


I came across a solution which suggested to check for broken lookup columns in the list and went ahead and deleted the broken lookup columns (which were looking up data which was not there) and then it let me to add the forms.

  • 1
    do not forget to refresh Sharepoint designer for getting new Metadata after removing invalid columns
    – Iman
    Commented Jun 26, 2014 at 8:26

Actually I found that issue started to appear when i tried to add field or new edit/display form to existing one, if there ware some documents in the library that were checked out or reserved by other people. When i deleted all the items (documents) or undone their reservation i was able to add edit/display forms again.


Solution for Sharepoint 2013... For me, I also had this problem...

Connect Problem

To see if you also have the same problem as me run the following powershell..

(Get-SpWeb https://url).ListTemplates | ? {$_.Name -eq $null }

Then if you get something with the guid "e374875e-06b6-11e0-b0fa-57f5dfd72085"

Disable-SPFeature -Identity "e374875e-06b6-11e0-b0fa-57f5dfd72085" -Url http://sitecollectionurl

will fix it. I had to delete my webcache in C:\Users\UserName\AppData\Local\Microsoft\WebsiteCache and reopen Sharepoint designer before designer would let me create the form though.

  • For the hack provided by user2855480: + 100 internet points. You sir are a scholar and a saint. Why microsoft allowed something like this to break key functionality in one of their most popular products.... we will never know. But I can confirm this work around resolved one of the issues I was having. Commented Jul 1, 2018 at 5:48

Check if your list has broken lookup columns.

  1. If found, delete broken lookup column.
  2. Close & Restart SharePoint Designer.
  3. Refresh List & Libraries in Designer (This will remove corrupted lookup column from schema & will update schema).
  4. Finally try to create new list form, you will be able to create list forms.

This worked for me :

delete my webcache in C:\Users\UserName\AppData\Local\Microsoft\WebsiteCache and reopen SharePoint designer before designer would let me create the form though. " Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.