0

I am using windows server 2012-R2 and which was having Office web apps configured previously. Due to some technical error server crashed and i re-installed it as per MSDN article. Note:- when i run New-OfficeWebAppsFarm command first time after server rebuild i get the error "Office web apps server has encountered an unrecoverable failure" , but this error is only one time , if i run the same command again with all properties second time, my Office web app deployment was successful and I can see the response correctly. But the problem is , when i try to set this server as OWA server from my SharePoint server getting the error as below.

New-SPWOPIBinding : Sorry, we have encountered an error and New-SPWOPIBinding
has failed.
At line:1 char:1
+ New-SPWOPIBinding -ServerName "servername.com" -AllowHTTP:$true
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Microsoft.Share...tNewWOPIBinding
   :SPCmdletNewWOPIBinding) [New-SPWOPIBinding], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewWOPIB

Response after running New-OfficeWebAppsFarm command second time

Response after running New-OfficeWebAppsFarm

When i try to check the deployement status again with command Get-OfficeWebAppsFarm getting this error.

get command error

0

I fixed the issue, There was an error in the web config file,

 <identity impersonate="true" /> 

was there and i changed it to

<trust level="Full" />

<system.web>                          <system.web>
    <identity impersonate="true" />             <trust level="Full" />
</system.web>                           </system.web>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.