User A needs access to a list. This list is already uninherited from the parent site.

I give User A read permissions, User A still cannot access list.

I add User A to a group with the same permissions (but also has permission to whole site), User A can access list.

Why is this? Is there something I'm missing? I am using the link directly to the list, so it should work, but user is given access denied until I add to specified group.

  • Can you check whether the User A has read access to the whole site when you are not adding it to a group? Is it just this particular list that he is not able to access? – Deepu Nair Jan 4 '12 at 3:52
  • I dont want him to have read access to the whole site, just the list that is in the site. I use the direct link to the list and he should be able to access it. – Mike Jan 4 '12 at 16:15

Chances are there are some elements on the page or master page which the user cannot access. Check the permissions for the group, what other permissions does the group have? Is your list using a lookup into another list (which that user would need read permission to as well).

You can also try running Fiddler to view the traffic requests when logged in as User A, see what is being called from where.


  • 1
    @Mike: To make sure that whether its your master page, you can simply make the v4.master as the default and try accessing the list. If it works, then scrutinize your master page for permission settings. – Deepu Nair Jan 5 '12 at 4:42
  • How would I troubleshoot the masterpage to what exactly they do not have access to so I can fix it? – Mike Mar 5 '12 at 15:08
  • 1
    Using Fiddler should identify what data the page is trying to access, and then returns an access denied – David Lozzi Mar 5 '12 at 15:12
  • 1
    Is it a custom master page? Check the permissions of the styles library in the root web. – David Lozzi Mar 5 '12 at 16:16
  • 1
    I dont think there is an easy way to determine this. If you masterpage is referencing lists directly, or assets like images, css, etc. check each element individually. – David Lozzi Mar 5 '12 at 19:28

I have to add to this answer. Once I made sure that SharePoint Designer allowed my custom masterpage and viewed it as indeed a masterpage (was a blank Content Type), the permissions worked fine. Previously, the masterpage that I previously had whenever I opened this ticket was 'invalid' and SharePoint wanted me to change it. Once I created a new masterpage and copied over the changes from the old masterpage, saved it, published it, and approved it, the permissions per list worked correctly so that the user could have access to a list without having permission to the whole page. The previous masterpage said access denied to the specific list URL for the user that had read access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.