1

I defined Document Set content type “A” (Engineering) to contain custom site metadata (for simplicity, call them 1, 2 and 3). I defined Document Set content type “B” (Energy Services) to contain custom site metadata (call them 4, 5 and 6). My custom metadata uses "lib." prefix for clarity.

Engineering content type (content type "A")

Energy Services content type (content type "B"

I created a document library and configured it to include instances of A and B along with default content types Document, Image, Video and a couple more.

Doc Set A created from Content Type A

Doc Set B created from Content Type B

Library properties showing Document Sets A and B included

When I am in Document Set A and upload a document, the metadata assignment screen shows me 1-3 as I expect, but it also shows 4-6 which do not apply to A;

Doc Set A asks for metadata from Doc Set B

likewise, when I am in B and upload a document, the assignment screen shows me 1-3 (which I do not want) along with 4-6.

Doc Set B upload asking for Doc Set A metadata

I cannot figure out how to restrict the metadata entry screen to just those columns defined within the content type.

If it’s relevant, I had another issue to solve: As shown in the Library Settings window, the default content types were not automatically “Used in” the document sets created from A and B even though I included the default types within A and B. As such, 1-6 were not appearing in the metadata assignment screen upon upload. So, in Library Settings I selected a default type (eg, “Document”) and manually added my custom site metadata 1-6 and that cured the issue. I don’t think it’s related to my existing issue, but thought I would mention it just in case.

It’s easy to get lost in the language...I hope this made sense.

Any suggestions?

  • Please add some screenshots of what you're experiencing. – jpollar Apr 20 at 13:18
  • Oops, noob here and I don't see an obvious way to upload images. – MarkB Apr 25 at 19:31
  • Figured out adding screen captures. – MarkB Apr 29 at 15:17
  • Still hoping someone can point me in the right direction... – MarkB May 13 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.