0

I have a custom news template in sitepages in a site collection which I do a "copy" and then publish whenever I want to make a new news article.

However, these news articles managed properties (firstpublisheddate, likescount, comments etc) is null when I extract them from the search schema, even if these properties should have data.

Even if the social bar contains likes or comments it does not show in a search connected to their managed properties.

In the search schema I have mapped (as a example) the CP ows_FirstPublishedDate to the FirstPublishedDate MP. Is there any reason why managed properties from the search schema is null, and is there anything I could try?

  • After you mapped the CP to the MP, did you recrawl the content? – Martin Muldoon Apr 17 at 19:46
0

Did the issue occur in SharePoint online or SharePoint on-premise?

If the issue occurs in SharePoint online, it runs the full crawl automatically. Then you could wait for a period of time to run crawl in SharePoint online.

If the issue occurs in SharePoint on-premise, then you could run a full crawl in search service application.

  • It's on SharePoint online. I did now notice on site contents (news articles) that the hidden property firstpublisheddate on news articles is null (and for some reason, sometimes get the correct date). Its very weird. Is it possible to turn on and off this feature? – Arte2 Apr 18 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.