0

Our SharePoint farm suddenly failed to run the profiles sync.

I have checked the Log file and found below ULS Log snipped which is not certain to any error.

"The Execute method of job definition Microsoft.Office.Server.UserProfiles.UserProfileImportJob (ID ab1ad955-29d5-40ea-9f8c-40a9f1b7d8c9) threw an exception. More information is included below.

Generic failure"

I have tried :

  1. Forefront Identity Manager Service and set the startup type to Automatic (Delayed Start).
  2. I granted the Network Service account basic "Read & Execute/List folder contents/Read" permissions to the C:\Program Files\Microsoft Office Servers\15.0 directory.

Nothing worked. SharePoint Keep logging the same ERROR

Snippet from Event Viewer: enter image description here Snippet from CA User Profile Service application: enter image description here Snippet from CA Timer Job History: enter image description here

Thank you in advance..

  • Is your user profile sync service running? You can check via Central Admin, services on the server . – Marek Sarad Apr 17 at 7:53
  • Yes FIM and FIM Sync services are running – mzonerz Apr 17 at 8:03
  • Have you tried running PSConfig \ Restarting the server? – Marek Sarad Apr 17 at 8:13
  • I cannot run PSConfig/ Restart the server as it is live.. any other solution? – mzonerz Apr 17 at 8:16
  • I am not using sync on my farms just import. In the past I had issue but it was relating to the sync service stopping, which you checked already. Have a look at this blog I used the steps in the past to troubleshoot: blog.devoworx.net/2012/10/30/user-profile-error – Marek Sarad Apr 17 at 8:22
1

Few things you could check is:

  1. Go to CA > Application Management > manage services on server. Make sure that User profile service and User Profile sync service is running.

  2. Application pool used by User Profile service Application in IIS.Make sure all are started

  3. The application pool account should be a domain user. Ensure if anyone has changed the application pool account. Go to Central Administrator > Security > Configure Service Account > Select the application pool and check the account for it.

If above do not work, you can try the solutions in below article:

https://blog.devoworx.net/2012/10/30/user-profile-error/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.