0

I have a very weird situation where I have three conditions that need to be met before the workflow should update another list with matching fields. The workflow fires but is updating only the first item in the list that doesn't match the conditions.

  1. If Segment = CurrentItem:Segment
  2. If Modality = CurrentItem:Modality
  3. If KPI = CurrentItem:KPI

Update Target and Update Actual.

It is only updating the first record and not even recognizing the conditions.

I am not able to get 2010 Workflows to even show an change.. I think there is still a bug with Microsoft.

I would appreciate any help.

Dorinda

1

How do you design your workflow?

And I designed a workflow to meet your requirement as the following,it could work well. You can have a try. enter image description here

enter image description here If the above also doesn't work for you, you can provide some screenshots about your workflow to understand your issue better.

And also,you can add a "Log to workflow history list" action after each condition like my workflow to check if it matches the condition.

  • I have done all that you have suggested and then some, the issue is that it is not recognizing them at all it is just updating the wrong record that only has one matching item in the criteria. We are going to try a brand new list and see if this is the cause of the issue. But so far nothing is working as expected with a very simple workflow. – Dorinda Apr 18 at 11:44
  • If possible,please provide some screenshots about your workflow design,so that I can test it as your steps. – Kally_MSFT Apr 19 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.