0

I am trying install custom bot on teams by AppStudio, but ambiguous error occurs on the bottom:

When I try to install bot

Manifest which I use to install bot:

{
    "$schema": "https://developer.microsoft.com/en-us/json-schemas/teams/v1.3/MicrosoftTeams.schema.json",
    "manifestVersion": "1.3",
    "version": "1.0.0",
    "id": "9bf3b749-ec5a-4cf2-94df-794a9898cc94",
    "packageName": "com.contoso.helloworld",
    "developer": {
        "name": "Contoso",
        "websiteUrl": "https://www.microsoft.com",
        "privacyUrl": "https://www.microsoft.com/privacy",
        "termsOfUseUrl": "https://www.microsoft.com/termsofuse"
    },
    "icons": {
        "color": "color.png",
        "outline": "outline.png"
    },
    "name": {
        "short": "Hello World",
        "full": "Hello World App"
    },
    "description": {
        "short": "Hello World App",
        "full": "This sample app provides a very simple app for Microsoft Teams. You can extend this to add more content and capabilities."
    },
    "accentColor": "#60A18E",
    "bots": [
        {
            "botId": "12d10a40-4886-4c55-a968-5898a4106c63",
            "scopes": [
                "personal",
                "team"
            ],
            "supportsFiles": false,
            "isNotificationOnly": false
        }
    ],
    "permissions": [
        "identity",
        "messageTeamMembers"
    ],
    "validDomains": []
}

As bot to test I use project from this repo.

Do you have idea how solve this problem or is place in AppStudio where I can find logs or description what cause this problem?

Ps. Also I found some links to similar issue on github. Is it possible that my tenant not allow app sideloading?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.