2

I have encountered a weird issue when i got a request to add a person in one of the security groups.what's odd is when i enter the login name of Christopher, another person is being added. they have the same login name.

enter image description here

enter image description here

enter image description here

so i check the user profiles in CA and checkd, but Claudia's profile is not found and i searched the login name and Christopher

enter image description here

0

Please check the user information list on the site you are trying to add new user. It is highly likely that those 2 users have the same username and the old one (claudia) has been deleted. the new one was create with the same user account. You can delete that entry from the information list but you will loose the history (like when the user edited something) Best practice when using SP with AD is to not delete accounts just disable this way you cannot create 2 accounts with previously used user name. You could correct that situation farm wide by using Move-SPUser cmdlet (where the old account and new one will be the same)

  • problem is when i go to the profiel of claudia in the user information list i get redirected to christopher's profile page. – Page F.P.T Apr 30 at 13:23
0

Have you changed the old user information to the new user before?

I ever met a similar issue because a user's information was changed and the change was not updated to user information list.

You can run the timer job “User Profile Service Application - User Profile to SharePoint Full Synchronization” in CA > Monitoring > Review job definitions. enter image description here

A similar blog for your reference:
How to update user display name in SharePoint

  • Unfortunately i wasnt the one who did the changes and i am not sure if her AD account was deleted or disabled. ill check this out. Thanks! – Page F.P.T Apr 16 at 12:29
  • how are things going there on this issue? – Kally_MSFT Apr 19 at 3:09
  • Hi @Kally_MSFT, i would still have to run full crawl this weekend because i am not sure is incremental crawl would suffice. will update you thern! – Page F.P.T Apr 24 at 1:58
  • hi @Kally_MSFT, i have checked the timer job but it runs hourly, and it ran just an hour ago but the issue is still there. – Page F.P.T Apr 25 at 9:19
  • hi @Kally_MSFT, i ran a full crawl over the weekend but checked now and still the same. i checked the _catalogs/users/simple.aspx and found that when i click on Claudia's profile, the information is on Christopher. – Page F.P.T Apr 29 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.