0

I'm getting the following error when trying to create a library called Projects:

"Projects" cannot be used as a site name. Site names cannot contain certain reserved words and cannot begin with an underscore.

I did some research and most people solved this by deleting a managed path on the web application. My problem is slightly different because I have this managed path in another web application and even deleting there is still giving me the same error. I thought it could be a SP2016 reserved word but I could create the same library in a dev farm I have from the company.

This is the config I have on 2 farms (1 dev and 1 non prod):

Both web application uses the same wildcard certificate and the same application pool (I tried with different app pools, same error). The webapp2 has the "projects" set as managed path, but I'm trying to create the library on the webapp1 that does NOT have the managed path.

I thought it could be some leftover from a migration, but I've just rebuild the farm with NO content and I'm still having the problem, so I guess is something on the configuration of the farm (Im using AutoSPInstaller).

  • Are you installing project server as well or is this just clean SP? – Marek Sarad Apr 15 at 12:38
  • Clean install, no project server, no User Profile or Mysites. – André Alves Apr 15 at 12:58
1

After half day digging into this issue, finally I found the problem, the AutoSPInstaller creates the managed paths per web application but also creates with the HostHeader parameter which means (according to the New-SPManagedPath) that the managed path applies to all host header site collection.

So, to remove it I used the code below:

Remove-SPManagedPath -Identity "projects" -HostHeader

After running this command I was able to create the library on any site collection of the webapp1.

One thing that I noticed, this configuration is not shown on the Central Admin, so it does not matter if you have deleted the managed path on the web application(s) (I tried) it will still be on the background as a HostHeader and therefore not possible to use for libraries/lists.

The lines of the AutoSPInstallerModule.psm1 that does this are the 3095 and 3102, just comment it if you dont need this config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.