I have an issue with the Content Editor Web Part. Whenever I edit the content I get the following error message:

"Cannot retrieve properties at this time."

and then when I click OK and proceed with editing, I click save, the following errors occurs:

"Cannot save your changes"

Can anyone help with an idea, suggestion?

  • What do you mean when you say "edit the content"? Is it that the tool pane doesn't show at all and you see the error or are you able to use the Rich Text Editor and/or the Source Editor, but then not save the changes? – Marc D Anderson May 3 '10 at 12:40
  • I can open the Rich text editor after the first error "Cannot retrieve properties at this time". After Editing in the Rich Text Editor when I click on save, I get the second error "Cannot save your changes" – Anonymous May 3 '10 at 16:10

We had a similar problem a while back and for us it involved a problem with the interaction between an on-screen web part and the edit page for the CEWP. We added some code to the master page to disable this web part when Edit mode was enabled which sovled it for us.


I resolved this problem by setting the external site name to intranet in AAM and in published rule in TMG set it to Forward the original host header instead of the actual one.

This resolved the problem for me.


An application pool recycle once helped, but that's no silver bullet. Need more research into that topic. I'm pretty sure you can edit and save the source code with level2 browsers like Firefox when IE fails like that.

  • Ya sure enough, fire fox stands as an alternate answer, but its not always applicable and is not permanent too. Although a ticket has been raised with MS for this, but something solid is yet to be decided upon. I think the root needs to be identified first. – Anonymous May 7 '10 at 3:41

HI - if this is a jQuery web part, you can check the existance of the edit page and only load jQuery if not in edit mode for MOSS 2007 by using the following.
if(document.getElementById('edmc2')==null) { //load jQuery }

This worked when I encountered a similar problem. you should then also test for jquery before use in your other web parts via

if(typeof(jQuery)!='undefined') { //do jquery stuff }

  • acutally this would be better: document.forms[0].elements["MSOLayout_InDesignMode"].value=="1" – tfforums Nov 23 '10 at 0:57

I can't explain the issue, but here is my suggestion. If this happens to you, add another CEWP to the page and transfer the content to it. Then delete the CEWP that was causing the issue. Painful, but this workaround is the best I have found so far.


I've seen this error when alternate access mapping were not set up correctly. We were using an ISA server to publish the site on a different url and port. After the AAM was corrected the web part worked fine.


Is there a definative answer here, we usually do an app pool recycle as well which resolves, the issue in most cases. Have yet to try alternate acceess mapping but thought I would see if that corrected the problem more than not.


If users still facing same issue with content editor,

check if browser version is greter than IE8

if that then change browser mode to IE8 or IE7 and try

for me this solves problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy