0

So here is an interesting question for anyone that might have any insight.

Some Background

I have recently worked on the creation of a site that needed a ton of workflows in the background, it uses a combination of 2010 and 2013 workflows.

The site didn't start off like this it was on a live site (I know bad form by me) as a quick set up that ballooned. So with that I took the site and moved it on to a test collection I have set up for just such things. So I shifted that between collections with PowerShell in the standard way (easy right).

With that I set about creating all the workflows and interlacing them between the list and blah blah blah. Everything went well everything was working as intended. Testing was done and all were happy.

So I move the subsite back across to the original site collection where it started life and here lies my issue, with the move everything was set up and working correctly; permissions, lists, libraries etc... the only thing that will not work is my 2013 workflows. The 2010 workflows work fine and are happy its just the 2013 ones.

I went to recreate the workflow from scratch on the subsite and designer will publish the workflow and give no errors and everything seems fine but when you go to the list you associate it to there is nothing. It doesn't even appear in the usual all files folder on Designer.

At first I thought OK its a designer issue so I;

  • Cleared caches, the standard (nope)
  • Reinstalled on machine (nope)
  • Got a new machine tried there (nope)
  • Tried creating it on the farm via the SPD there (nope)

So I figure it might be a site issue but;

  • I have checked features on the site (all good)
  • I have checked workflows for 2013 on higher levels of the site (all good)
  • I have checked workflows on other sites at an equal level (all good)
  • I have checked the accounts (all good)
  • I have checked farm features (all good)
  • IIS (all good)
  • I have moved a list from the subsite to another and added 2013 workflows (all good)

I have sort of run out of ideas as to what could cause this. Does anyone have any other suggestions?

I will be just shifting lists to a new site because I am aging too rapidly with this issue. But out of morbid curiosity I do want to figure it out.

  • Why using a combination of the WF2010 and 2013? couldn't achieve something with WF2010? WF2013 is flaky platform. We used it in one project and failed miserably. It seems there aren't even people at MS to know how to support it. Even with Premier support you get WF experts and SharePoint ones but i still need to see one that knows both products and how they interact. – Marek Sarad Apr 10 at 13:48
  • Have you tried to publish simple WF2013 on that site. At one point in the project that solved an issue for me. WF stopped working. but after I created a simple one that just saved hello world to history everything else started working. – Marek Sarad Apr 10 at 13:49
  • Hi @MarekSarad. Thanks for the response, you are right about MS not knowing what to do with it. I have indeed tried just creating a simple WF and publishing that, and the results are the same. It goes through fine in the eyes of the designer but when you go to see it on the site or in the SPD All files location there is nothing there. I would guess that the reasoning behind this odd error is one that will remain a mystery forever! – Chris. D Apr 12 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.