0

I am new to SharePoint world, working in nonprofit.

I am experiencing an issue with SharePoint 2010. The new users from Active directory are not getting added into User Information list however profile of new users are added in central administration from AD and FIM is not showing any error. I read this article and last sync is today but still cannot see user in user information list.

  • Have you granted the users permissions in this site collection? – Michael Han_MSFT Apr 8 '19 at 9:57
1

User get added in User Information list on when

When we grant any user permissions to a user, they are added automatically to the hidden User Information list a new item will be created in the User Information List storing some information about the user.

Even though if we grant access to any active directory group the group gets added to the hidden User Information list as well but the user does not get added until they access the site. (As an example, I granted an AD group permissions to my site & only the AD group showed up in the hidden User Information list not the users

It has been changed little bit in SharePoint 2013. As it shows user in list as soon as I give them permission to site regardless of they logon or not

Ref link - https://gallery.technet.microsoft.com/office/User-Information-List-in-8b420e8c

Hope this helps...happy coding...!!!

  • I cannot see the user in user information list. – shaadi Apr 9 '19 at 1:08
  • have you given permission to user on site collection..then only it would add to user information list... – Siddharth Vaghasia Apr 17 '19 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.