1

I am getting following error:

Failed to create sample data.
An exception of type System.TypeLoadException was thrown.  Additional exception information: Could not load type 'Microsoft.SharePoint.Administration.SPIdentifierType' from assembly 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'.
System.TypeLoadException: Could not load type 'Microsoft.SharePoint.Administration.SPIdentifierType' from assembly 'Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'.
   at Microsoft.Office.Server.Administration.SPAclFormatter.Deserialize[TRights](XmlReader xmlReader, SPAcl`1 acl)
   at Microsoft.Office.Server.Administration.SPAclFormatter.Deserialize[TRights](String serializedAcl)
   at Microsoft.Office.Server.Administration.UserProfileApplication.Synchronize()
   at Microsoft.Office.Server.Administration.UserProfileApplication.Install()
   at Microsoft.Office.Server.Administration.UserProfileApplication.Provision()
   at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.ProvisionServiceApplicationsAndProxies()
   at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

1 Answer 1

1

It could be basically some patch update issue. Are you running the configuration wizard for the first time?

There is a technet blog for some better understanding, where it says KB2560890 could be the issue. No guarantees though.

Do you have SharePoint SP1 installed? Have you updated to the latest cumulative update for SharePoint. Better apply all the latest patches and cumulative updates and this should get resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.